分类: nodejs

package.json 里的依赖怎么写

Dependencies
可选字段,指示当前包所依赖的其他包。

{ “dependencies” :
{ “foo” : “1.0.0 – 2.9999.9999”
, “bar” : “>=1.0.2 <2.1.2”
, “baz” : “>1.0.2 <=2.3.4”
, “boo” : “2.0.1”
, “qux” : “<1.0.0 || >=2.3.1 <2.4.5 || >=2.5.2 <3.0.0”
, “asd” : “http://asdf.com/asdf.tar.gz”
, “til” : “~1.2”
, “elf” : “~1.2.3”
, “two” : “2.x”
, “thr” : “3.3.x”
}
}
版本格式可以是下面任一种:

version 完全匹配

version 大于这个版本
=version大于或等于这个版本
=version1 <=version2.
range1 || range2 满足任意一个即可
git… Git地址
user/repo
devDependencies
可选字段。如果只需要下载使用某些模块,而不下载这些模块的测试和文档框架,放在这个下面比较不错。

peerDependencies
可选字段。兼容性依赖。如果你的包是插件,适合这种方式。

bundledDependencies
可选字段。发布包时同时打包的其他依赖。

optionalDependencies
可选字段。如果你想在某些依赖即使没有找到,或则安装失败的情况下,npm都继续执行。那么这些依赖适合放在这里。

Share